[pc110] Has anybody tried the IBM Microdrive on the PC110

Oscar M. Siguenza (osiguenz nospam at fmi.fujitsu.com)
Tue, 10 Aug 1999 08:25:24 -0700

Hi Everyone,

Has anyone tried to use the IBM Microdrive on the PC110? I just
got one this weekend. If you are planning to buy one be aware that
the drive does not fit on the CFlash slot of the PC110, it is too
thick (the drive is the same thickness as a PCMCIA Type II slot and
the PC110 only has a Type I thick CFlash slot).

In any case I got it to fit in one on the PCMCIA slots after I
modified a CFlash to PCMCIA adapter. A normal adapter only accomodates
a Type I thick card.

I have tried installing slackaware 4.0 and 3.4 as well as use my old
kernel on it. Everytime things look alright but when the PC110 goes
to sleep and comes back up it seems that the drive does not get reset
correctly. I get a lot of errors with the drive missing "interrupts"

hdc: drive_cmd: status=0x51 { DriveReady SeekComplete Error }
hdc: drive_cmd: error=0x04 { DriveStatus Error }

Has anyone look into the PCMCIA services to see what the problem
might be? I remember having this kind of problems with a simple
technology CFlash card, so I think it is a recurring error.

I am running PCMCIA services 2.9.9 on kernel 2.0.30, if anybody
has any useful information on this I would like to hear it. Otherwise
my $400+ investment to make the PC110 more useful may go down the
tubes (or I will have to figure out how to hack it, considering the
time I got the machine may well be too obsolete by the time I
finish :( ). I guess worse case I will have to buy a camera that
can use this drive :( .

Oscar S.

/* Oscar M. Siguenza                                                 */
/* EMAIL: osiguenz nospam at fmi.fujitsu.com                                   */